This Android SDK requires Android Developer Toolkit version 22.0.0 or above.

ISSUE: This Android SDK requires Android Developer Toolkit version 22.0.0 or above.  Current version is 21.1.0.2013-2-6-0-46.  Please update ADT to the latest version.



SOLUTION:

  1. Run Eclipse as administrator.
  2. Go to HelpInstall New Software.
  3. On Work with: type https://dl-ssl.google.com/android/eclipse/ and press ENTER.

  4. Wait for Eclipse to fetch the repository. An item named Developer tools will appear in the list.
    Mark it for install, press Next and follow the steps to install the ADT tools.
  5. When finished, it will ask to restart Eclipse. Make sure you do this.
  6. When Eclipse restarts, all your Android SDK packages should show up again.

Post a Comment